User Tools

Site Tools


replicator_agent_requirements

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
replicator_agent_requirements [2018/11/30 00:15]
timothy.pike [Supported Databases]
replicator_agent_requirements [2020/02/19 11:53] (current)
paul [Supported Operating Systems]
Line 1: Line 1:
 ===== Agent Requirements ===== ===== Agent Requirements =====
- 
-<wrap round info>​[[dubnium_release|Dubnium]]</​wrap>​ 
  
 These are the requirements needed to ensure that your agent can be executed properly and has the ability to be upgraded in the future. These are the requirements needed to ensure that your agent can be executed properly and has the ability to be upgraded in the future.
Line 29: Line 27:
 ==== Java ==== ==== Java ====
  
-Both 32 and 64 bit versions of Java are supported. The Java version must be 1.7 or 1.8.  +Both 32 and 64 bit versions of Java are supported. The Java version must be Java 8 or higher
-It's strongly recommended that you use a server type JVM instead of a client or desktop version. ​+As of the [[https://​doc.perspectium.com/​display/​fluorine|Fluorine release]], Java versions 9 and 10 are supported. ​It's strongly recommended that you use a server type JVM instead of a client or desktop version. ​
  
 **A 32 bit version of Java is required if you're running the agent on a Windows server for Agent versions under 3.24.0.**  ​ **A 32 bit version of Java is required if you're running the agent on a Windows server for Agent versions under 3.24.0.**  ​
Line 42: Line 40:
 If you don't see something like the following then please contact your system administrator for help. If you don't see something like the following then please contact your system administrator for help.
 <code bash> <code bash>
-java version "1.7.0_65"+java version "1.8.0_181"
 </​code>​ </​code>​
  
Line 61: Line 59:
  
 ^ Database ​     ^ Version ​     ^ ^ Database ​     ^ Version ​     ^
-| Oracle ​   | 12c Release 1: 12.1.0.2+     |  +| Oracle ​   | 11g, 12c Release 1: 12.1 - 12.2.0.1.0    ​|  
-| SQL Server (MSSQL) ​   | 2012+, 2016 recommended | +| SQL Server (MSSQL) ​   | 2012, 2016 recommended | 
-| MySQL  | 5.7.22 or older; MySQL 8 supported in [[europium_release|Europium]] ​   |  +| MySQL  | 5.6 - 8.0 supported in [[europium_release|Europium]] ​   |  
-| SAP Hana | SPS 12|+| SAP Hana | SPS 12 |
 | Amazon Redshift | 4.0-4.1 | | Amazon Redshift | 4.0-4.1 |
 | Amazon Aurora (MySQL compatible) | N/A | | Amazon Aurora (MySQL compatible) | N/A |
-| IBM DB2 | 11+| IBM DB2 | 11 | 
-| HP Vertica | 8.0+| HP Vertica | 8.0 - 9.21 
-| PostgreSQL | 42.1.|+| PostgreSQL | 42.2.6 | 
 +| Snowflake | 3.|
  
-  __**Note: Perspectium uses the newest version of each of the associated JDBC drivers, which are included ​ +**NOTE:** Perspectium uses the newest version of each of the associated JDBC drivers, which are included with the install.
-        ​with the install.+
         ​         ​
-  __**Note**__: Perspectium strongly recommends placing the Agent on the same local area network as the database server.+**NOTE:** Perspectium strongly recommends placing the Agent on the same local area network as the database server.
   ​   ​
 ====Supported Operating Systems==== ====Supported Operating Systems====
Line 81: Line 79:
  
 ^ OS      ^ Version ​     ^ ^ OS      ^ Version ​     ^
-| Windows Professional & Home  | 7    |  +| Windows Professional & Home  | 7 - 10     |  
-| Windows Server ​   | 12+ +| Windows Server ​   | 2012 - 2016 
-| Linux Redhat/​AIX ​ ​| ​All    ​+| Linux Ubuntu ​ ​| ​14.04 and 16.04  ​
  
replicator_agent_requirements.1543565718.txt.gz · Last modified: 2018/11/30 00:15 by timothy.pike